summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-04-23 20:01:48 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-04-23 22:48:19 +0200
commita71d769d1e230463a043e12a10a557fb0c0aa8c4 (patch)
treec07fba64baedacbb938c9c215f463ba2018b11bc
parentd28fa5cc70d3c0fd79d547d37529a048c90fce16 (diff)
gnu: r-minimal: Update to 3.4.0.
* gnu/packages/statistics.scm (r-minimal): Update to 3.4.0. [arguments]: Set timezone to UTC+1 in "set-timezone" phase to avoid regression test failure.
-rw-r--r--gnu/packages/statistics.scm20
1 files changed, 11 insertions, 9 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 4882ca7bac..f1fcbe083d 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -106,7 +106,7 @@ be output in text, PostScript, PDF or HTML.")
(define-public r-minimal
(package
(name "r-minimal")
- (version "3.3.3")
+ (version "3.4.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://cran/src/base/R-"
@@ -114,7 +114,7 @@ be output in text, PostScript, PDF or HTML.")
version ".tar.gz"))
(sha256
(base32
- "0v7wpj89b0i3ad3fi1wak5c93hywmbxv8sdnixhq8l17782nidss"))))
+ "14cb8bwi3akvdb6934kqic2862f2qgav6cq4g0h7gi2p4ka9x3i8"))))
(build-system gnu-build-system)
(arguments
`(#:disallowed-references (,tzdata-2017a)
@@ -184,13 +184,15 @@ be output in text, PostScript, PDF or HTML.")
;; making "help()" print nothing at all.
(lambda _ (setenv "PAGER" "cat") #t))
(add-before 'check 'set-timezone
- ;; Some tests require the timezone to be set.
- (lambda* (#:key inputs #:allow-other-keys)
- (setenv "TZ" "UTC")
- (setenv "TZDIR"
- (string-append (assoc-ref inputs "tzdata")
- "/share/zoneinfo"))
- #t))
+ ;; Some tests require the timezone to be set. However, the
+ ;; timezone may not just be "UTC", or else a brittle regression
+ ;; test in reg-tests-1d will fail.
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "TZ" "UTC+1")
+ (setenv "TZDIR"
+ (string-append (assoc-ref inputs "tzdata")
+ "/share/zoneinfo"))
+ #t))
(add-after 'build 'make-info
(lambda _ (zero? (system* "make" "info"))))
(add-after 'build 'install-info