summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-04-24 12:55:00 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-04-26 12:04:26 +0300
commitb27aacbfe2e955e2a29113f6178971541b6655db (patch)
tree4a6053638bdf1c23a335431cce565e3bcaf6e7d5
parent4ad70ad8dee6af12ca6ac93685b9f0a6d81221a4 (diff)
gnu: Add gcompris-qt.
* gnu/packages/education.scm (gcompris-qt): New variable.
-rw-r--r--gnu/packages/education.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 808be203c2..b600c2ee39 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -28,6 +29,7 @@
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages kde-frameworks) ; extra-cmake-modules
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
@@ -102,6 +104,49 @@ of categories with some of the activities available in that category.
")
(license license:gpl3+)))
+(define-public gcompris-qt
+ (package
+ (name "gcompris-qt")
+ (version "0.70")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://gcompris.net/download/qt/src/gcompris-qt-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "01r7i8dmwb2nlfyp0y0mzs8yydmvn5gq7xn1w7g21lysak1mliwa"))))
+ (build-system cmake-build-system)
+ (arguments
+ ;; Qml_box2d is unmaintained and not actually required for building
+ '(#:configure-flags (list "-DQML_BOX2D_MODULE=disabled")
+ #:tests? #f)) ; no test target
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("gettext" ,gettext-minimal)
+ ("perl" ,perl)))
+ (inputs
+ `(("python-2" ,python-2)
+ ("qt" ,qt))) ; Cannot find qtquick at runtime with modular qt.
+ (home-page "http://gcompris.net/index-en.html")
+ (synopsis "Educational games for small children")
+ (description
+ "Gcompris offers a large collection of educational games for small
+children, designed to be a unified interface to integrate more educational
+games. Language-oriented games contain vocabulary, sounds, and voices for
+many different languages.
+Currently available boards include:
+@enumerate
+@item learning how to use a mouse and keyboard
+@item learning simple arithmetic
+@item learning how to read an analog clock
+@item recognize letters after hearing their names
+@item reading practice
+@item small games (memory games, jigsaw puzzles, ...)
+@end enumerate\n")
+ (license license:gpl3+)))
+
(define-public tipp10
(package
(name "tipp10")