summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-04-26 13:17:12 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-04-26 22:04:01 +0300
commitbe58ffa4aa518686294726bdd83733eca4e6c03c (patch)
tree0d2c3bc87a4a56060db8007e395817183dab0aa7
parentc9ba67a5f2a2fe48dd42649db46287ec54290579 (diff)
gnu: owncloud-client: Update to 2.3.1.
* gnu/packages/sync.scm (owncloud-client): Update to 2.3.1. [arguments]: Enable more tests.
-rw-r--r--gnu/packages/sync.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index 4b026b93cb..91f4b3d0ed 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
@@ -35,14 +35,14 @@
(define-public owncloud-client
(package
(name "owncloud-client")
- (version "2.2.4")
+ (version "2.3.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://download.owncloud.com/desktop/stable/"
"owncloudclient-" version ".tar.xz"))
(sha256
- (base32 "1lz7v5sscj5489panz5ng372g9l66ng0srx6xaz8drnsgi7m64zk"))
+ (base32 "051rky4rpm73flxxkhfdxqq23ncnk4ixhscbg74w82sa4d93f54k"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -75,11 +75,9 @@
(("\\/\\$\\{APPLICATION_EXECUTABLE\\}\\\"") "\""))
#t))
(add-after 'unpack 'delete-failing-tests
- ;; These tests fail for no apparent reason
+ ;; "Could not create autostart folder"
(lambda _
(substitute* "test/CMakeLists.txt"
- (("owncloud_add_test\\(FileSystem \"\"\\)" test)
- (string-append "#" test))
(("owncloud_add_test\\(Utility \"\"\\)" test)
(string-append "#" test)))
#t)))