summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-04-25 16:10:49 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-04-26 11:39:33 +0200
commitce09f04ea0b565f9096926a931eebc167ae10a37 (patch)
treecf601100780211a8c48e35f4d4a3982e88953976
parent011b858b947895a5d164abea18c4332532b5a67b (diff)
gnu: ceph: Update to 12.0.2.
* gnu/packages/storage.scm (ceph): Update to 12.0.2. [arguments]<#:phases>: Disable new test. * gnu/packages/patches/ceph-disable-cpu-optimizations.patch: Adjust.
-rw-r--r--gnu/packages/patches/ceph-disable-cpu-optimizations.patch10
-rw-r--r--gnu/packages/storage.scm5
2 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/patches/ceph-disable-cpu-optimizations.patch b/gnu/packages/patches/ceph-disable-cpu-optimizations.patch
index 56a1654f29..f33eb629d6 100644
--- a/gnu/packages/patches/ceph-disable-cpu-optimizations.patch
+++ b/gnu/packages/patches/ceph-disable-cpu-optimizations.patch
@@ -15,16 +15,16 @@ don't add anything for i686.
#
# SIMD_COMPILE_FLAGS
#
-@@ -56,7 +51,7 @@
- if(HAVE_ARM_NEON)
+@@ -73,7 +68,7 @@
set(SIMD_COMPILE_FLAGS "${SIMD_COMPILE_FLAGS} -mfpu=neon")
endif()
+
-elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "i386|i686|amd64|x86_64|AMD64")
+elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "amd64|x86_64|AMD64")
set(HAVE_INTEL 1)
CHECK_C_COMPILER_FLAG(-msse HAVE_INTEL_SSE)
if(HAVE_INTEL_SSE)
-@@ -66,24 +61,4 @@
+@@ -83,26 +78,6 @@
if(HAVE_INTEL_SSE2)
set(SIMD_COMPILE_FLAGS "${SIMD_COMPILE_FLAGS} -msse2")
endif()
@@ -48,4 +48,6 @@ don't add anything for i686.
- if(HAVE_INTEL_SSE4_2)
- set(SIMD_COMPILE_FLAGS "${SIMD_COMPILE_FLAGS} -msse4.2")
- endif()
- endif()
+ elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "(powerpc|ppc)64le")
+ set(HAVE_PPC64LE 1)
+ message(STATUS " we are ppc64le")
diff --git a/gnu/packages/storage.scm b/gnu/packages/storage.scm
index 388eb10444..5d647bcd34 100644
--- a/gnu/packages/storage.scm
+++ b/gnu/packages/storage.scm
@@ -48,14 +48,14 @@
(define-public ceph
(package
(name "ceph")
- (version "12.0.1")
+ (version "12.0.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.ceph.com/tarballs/ceph-"
version ".tar.gz"))
(sha256
(base32
- "1mgd7iqx9zgwims2bb8dbzhzv0p6z9vjxavbv8dampa34fzac3xc"))
+ "0l9v072ba28i984y5rwny9i11nmpyx5bl7awxg48plyadm2l3g14"))
(patches
(search-patches "ceph-skip-unittest_blockdev.patch"
"ceph-skip-collect-sys-info-test.patch"
@@ -223,6 +223,7 @@
(substitute* "src/test/osd/CMakeLists.txt"
(("^add_ceph_test\\(osd-bench\\.sh.*$") "\n")
(("^add_ceph_test\\(osd-config\\.sh.*$") "\n")
+ (("add_ceph_test\\(osd-dup\\.sh.*$") "\n")
(("^add_ceph_test\\(osd-markdown\\.sh.*$") "\n")
(("^add_ceph_test\\(osd-reactivate\\.sh.*$") "\n")
(("^add_ceph_test\\(osd-reuse-id\\.sh.*$") "\n")