summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Allan Webber <cwebber@dustycloud.org>2017-04-25 00:18:29 -0500
committerChristopher Allan Webber <cwebber@dustycloud.org>2017-04-25 22:44:52 -0500
commitd26ae96c3da6d968cd38348197f3581e456e56cc (patch)
tree5efefbfde7d0318dcb2e3595af04776b43bcb095
parent623fb4d1629adfa97e3fe412d394ca0490742f29 (diff)
gnu: Add guile-sjson.
* gnu/packages/guile.scm (guile-sjson): Add guile-sjson.
-rw-r--r--gnu/packages/guile.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 9dd524e4b2..26606f9d36 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -1768,4 +1768,33 @@ HTML (via SXML) or any other format for rendering.")
(home-page "http://dthompson.us/software/guile-syntax-highlight")
(license license:lgpl3+))))
+(define-public guile-sjson
+ (package
+ (name "guile-sjson")
+ (version "0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://dustycloud.org/misc/sjson-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "09hnh2brc7ihh8dv4g5hdmdj8rs8p9l3pmlgafkx145grdg7wprx"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'bootstrap
+ (lambda _ (zero? (system* "sh" "bootstrap.sh")))))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("guile" ,guile-2.2)))
+ (home-page "https://gitlab.com/dustyweb/guile-sjson")
+ (synopsis "S-expression based json reader/writer for Guile")
+ (description "guile-sjson is a json reader/writer for Guile.
+It has a nice, simple s-expression based syntax.")
+ (license license:lgpl3+)))
+
;;; guile.scm ends here