summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-04-24 17:51:47 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-04-24 19:30:02 +0300
commitf0ef7b47d3d7ff2a0200e084639bb93252e21c1b (patch)
tree883b6fb6c8370e97999a4dfc3a8f0c2a43f3ee8f
parent0611abff32ddf0dd6cfbbff74aee4c9a7abe1936 (diff)
gnu: libevent: Disable regress tests.
* gnu/packages/libevent.scm (libevent)[arguments]: Disable the 'regress' tests.
-rw-r--r--gnu/packages/libevent.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index 4aab447333..5d769aaf47 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -51,6 +52,9 @@
;; https://github.com/libevent/libevent/issues/452
"libevent-2.1-skip-failing-test.patch"))))
(build-system gnu-build-system)
+ (arguments
+ ;; This skips some of the tests which fail on armhf and aarch64.
+ '(#:configure-flags '("--disable-libevent-regress")))
(inputs
`(("python" ,python-2))) ; for 'event_rpcgen.py'
(native-inputs
@@ -87,7 +91,8 @@ loop.")
"libevent-2.0-CVE-2016-10195.patch"
"libevent-2.0-CVE-2016-10196.patch"
"libevent-2.0-CVE-2016-10197.patch"
- "libevent-2.0-evbuffer-add-use-last-with-datap.patch"))))))
+ "libevent-2.0-evbuffer-add-use-last-with-datap.patch"))))
+ (arguments '())))
(define-public libev
(package