summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-04-23 22:16:46 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-04-23 22:16:46 +0300
commitf3bd17281a325532b2305ef2e464237f0e3074b1 (patch)
treefe4428d513f7f1696230a259d4819f2bd275266c
parent769df80ded6057548a31571a49bc60cc8cf8f0be (diff)
gnu: obs: Mark as supported only on Intel systems.
* gnu/packages/video.scm (obs)[supported-systems]: New field. [arguments]: Remove armhf and mips specific substitutions.
-rw-r--r--gnu/packages/video.scm17
1 files changed, 2 insertions, 15 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 082826acaf..49408ab53f 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -36,7 +36,6 @@
(define-module (gnu packages video)
#:use-module (ice-9 match)
#:use-module (srfi srfi-1)
- #:use-module (srfi srfi-26)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix utils)
#:use-module (guix packages)
@@ -1614,20 +1613,7 @@ be used for realtime video capture via Linux-specific APIs.")
"043f8mfdh4ll0hpivpyg3iniirckwsgri0gzamyrba1yhf2c2ibr"))))
(build-system cmake-build-system)
(arguments
- `(#:tests? #f ; no tests
- ,@(if (any (cute string-prefix? <> (or (%current-target-system)
- (%current-system)))
- '("arm" "mips"))
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'remove-architecture-specific-instructions
- ;; non-Intel platforms fail to build with the architecture
- ;; specific compiler flags included by default.
- (lambda _
- (substitute* "libobs/CMakeLists.txt"
- (("if\\(NOT MSVC\\)") "if(MSVC)"))
- #t))))
- '())))
+ `(#:tests? #f)) ; no tests
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
@@ -1654,6 +1640,7 @@ video recording and live streaming. OBS supports capturing audio and video
from many input sources such as webcams, X11 (for screencasting), PulseAudio,
and JACK.")
(home-page "https://obsproject.com")
+ (supported-systems '("x86_64-linux" "i686-linux"))
(license license:gpl2+)))
(define-public libvdpau