summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:20:25 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:07:50 +0200
commit21f2ef04e8d78116510b252f8015e1a8dbacc7cf (patch)
treeaa3c9410b4e8a9d8aebc3b90d0eb85f348945500
parent223b7250775ffe0024b68031d5c811359076f099 (diff)
gnu: Add texlive-scheme-full.
* gnu/packages/tex.scm (texlive-scheme-full): New variable.
-rw-r--r--gnu/packages/tex.scm53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d2484ef04c..48c4b10514 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -903,6 +903,59 @@ mathematical or other technical packages.")
(description "This is the TeX Live scheme for installing ConTeXt.")
(license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
+(define-public texlive-scheme-full
+ (package
+ (name "texlive-scheme-full")
+ (version (number->string %texlive-revision))
+ (source #f)
+ (build-system trivial-build-system)
+ (arguments (list #:builder #~(mkdir #$output)))
+ (propagated-inputs
+ (list texlive-collection-basic
+ texlive-collection-bibtexextra
+ texlive-collection-binextra
+ texlive-collection-context
+ texlive-collection-fontsextra
+ texlive-collection-fontsrecommended
+ texlive-collection-fontutils
+ texlive-collection-formatsextra
+ texlive-collection-games
+ texlive-collection-humanities
+ texlive-collection-langarabic
+ texlive-collection-langchinese
+ texlive-collection-langcjk
+ texlive-collection-langcyrillic
+ texlive-collection-langczechslovak
+ texlive-collection-langenglish
+ texlive-collection-langeuropean
+ texlive-collection-langfrench
+ texlive-collection-langgerman
+ texlive-collection-langgreek
+ texlive-collection-langitalian
+ texlive-collection-langjapanese
+ texlive-collection-langkorean
+ texlive-collection-langother
+ texlive-collection-langpolish
+ texlive-collection-langportuguese
+ texlive-collection-langspanish
+ texlive-collection-latex
+ texlive-collection-latexextra
+ texlive-collection-latexrecommended
+ texlive-collection-luatex
+ texlive-collection-mathscience
+ texlive-collection-metapost
+ texlive-collection-music
+ texlive-collection-pictures
+ texlive-collection-plaingeneric
+ texlive-collection-pstricks
+ texlive-collection-publishers
+ texlive-collection-xetex))
+ (home-page "https://www.tug.org/texlive/")
+ (synopsis "TeX Live full scheme (everything)")
+ (description
+ "This is the full TeX Live scheme: it installs everything available.")
+ (license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
+
(define-public texlive-scheme-gust
(package
(name "texlive-scheme-gust")