summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:05:16 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:07:37 +0200
commit237d99349ee4025e00d3ffdd8c3e28638d46aa28 (patch)
treeb1a1d924322fd11c6a672084372ed004743384dc
parentabb2ae4b83681977d08abe9ab963e71d0e79de89 (diff)
gnu: Add texlive-xltabular.
* gnu/packages/tex.scm (texlive-xltabular): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8793a3d417..ecb8f9fcbd 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -100315,6 +100315,27 @@ same name to the same color. This package makes the collected color names
usable with LaTeX.")
(license (list license:lppl1.3c license:cc0))))
+(define-public texlive-xltabular
+ (package
+ (name "texlive-xltabular")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/xltabular/"
+ "tex/latex/xltabular/")
+ (base32
+ "08wpgf2w0pcl2nqm2mgplxvy9q0zbszd5lm4rqzkz3vyi6zlravm")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/xltabular")
+ (synopsis "@code{longtable} support with possible X-column specifier")
+ (description
+ "This package loads package @code{ltablex}, but keeps the current
+@code{tabularx} environment as is. The new environment @code{xltabular} is
+a combination of @code{longtable} and @code{tabularx}: Header/footer
+definitions, X-column specifier, and with possible pagebreaks.")
+ (license license:lppl1.3+)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar