summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:05:27 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:07:42 +0200
commit4ae60bdb5e459f1ebce64681752348e6394d82fc (patch)
treed6fc6ba8fddcdf9fded392c1232451352b590846
parent1e857477c52430df3fce4513eddbc927c712ab8e (diff)
gnu: Add texlive-xurl.
* gnu/packages/tex.scm (texlive-xurl): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bd0819a427..5eb962b71b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -100524,6 +100524,26 @@ various long-standing issues.")
@code{xtabular} environment provides tables that break across pages.")
(license license:lppl)))
+(define-public texlive-xurl
+ (package
+ (name "texlive-xurl")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/xurl/" "tex/latex/xurl/")
+ (base32
+ "0g03b27vg4qmprjy7jlpvpvq0223xsjfd6ynhsfwglqva3yq70ri")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/xurl")
+ (synopsis "Allow URL breaks at any alphanumerical character")
+ (description
+ "This package loads @code{url} by default and defines possible URL breaks for
+all alphanumerical characters, as well as @samp{=}, @samp{/}, @samp{.},
+@samp{:}, @samp{*}, @samp{-}, @samp{~}, and @samp{\"}. All arguments which
+are valid for @code{url} can be used and will be passed on to this package.")
+ (license license:lppl1.3+)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar