summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:04:36 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:07:23 +0200
commit59d2a64002c91133403053085ed2668a690a1560 (patch)
tree11c1a3c79e9ae1a5d4537d3a57ed19926cb98b89
parenta8974cd458cc0a707376d50f165123c9b3b331e2 (diff)
gnu: Add texlive-volumes.
* gnu/packages/tex.scm (texlive-volumes): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a8fd6b4f20..14312906f1 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -99535,6 +99535,28 @@ job done. If you are looking for something more elaborate try the
@code{geometry} package.")
(license license:lppl)))
+(define-public texlive-volumes
+ (package
+ (name "texlive-volumes")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/volumes/" "source/latex/volumes/"
+ "tex/latex/volumes/")
+ (base32
+ "06q6p31m11p3iavksrs7hrbgbsmxhfsq0qh3h96jch0xf46dyy4c")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/volumes")
+ (synopsis "Typeset only parts of a document, with complete indexes etc")
+ (description
+ "This package helps you if you want to produce separate printed volumes from
+one LaTeX document, as well as one comprehensive, all-inclusive version. It
+suppresses the part of the table of contents that are not typeset, while
+counters, definitions, index entries etc., are kept consistent throughout the
+input file.")
+ (license license:lppl)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar