summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:05:23 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:07:40 +0200
commit59ececa5584e765bd52c88e1d01966a12115195d (patch)
treeb018f7b7562794d99714a37388b2b23264b90251
parent339e10cf48878b90db7b5cbefc27601e61c654b4 (diff)
gnu: Add texlive-xsavebox.
* gnu/packages/tex.scm (texlive-xsavebox): New variable.
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b50c7127f9..42dbf7cea1 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -100461,6 +100461,31 @@ follows them in the command stream and choose appropriate behaviour.")
a variety of units. It can handle all units supported by TeX.")
(license license:lppl1.3+)))
+(define-public texlive-xsavebox
+ (package
+ (name "texlive-xsavebox")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/xsavebox/"
+ "source/latex/xsavebox/"
+ "tex/latex/xsavebox/")
+ (base32
+ "1k055jv83yk17f7l8bvg8mvm7cw7afry7sykli4fbz8w0yjq3yci")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/xsavebox")
+ (synopsis "Saveboxes for repeating content without code replication")
+ (description
+ "The package defines commands for saving content that can be repeatedly placed
+into the document without replicating DVI/PDF code in the output file,
+allowing for smaller file size of the final PDF and improved content caching
+for faster display in certain PDF viewers. The method makes use of Form
+XObjects defined in the PDF specification. The user commands are modelled
+after the standard LaTeX commands @code{\\savebox}, @code{\\sbox},
+@code{\\usebox} and the @code{lrbox} environment.")
+ (license license:lppl)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar