summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-08-31 12:41:17 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-01 01:25:33 -0400
commit62075c6be4242866cf75c480115382568784a4b9 (patch)
tree5896bd467857f876afc382cce630833507e5a535
parentc7c500dd61ec4bf6feb9769858b3a7041c9ace71 (diff)
gnu: svt-hevc: Mention the package should not be used as an input.
* gnu/packages/video.scm (svt-hevc): Add a warning comment, as well as some extra explanation to the description. [home-page]: Update URL.
-rw-r--r--gnu/packages/video.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index ff52b9b38d..78202be471 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -319,6 +319,8 @@ video and audio streams from a DVD.")
"https://linuxfromscratch.org/blfs/view/svn/multimedia/transcode.html")
(license license:gpl2+)))
+;;; Warning: this package shouldn't be added as an input anywhere, as it can
+;;; only be used for recent x86_64 CPUs implementing the AVX2 instruction!
(define-public svt-hevc
(package
(name "svt-hevc")
@@ -341,11 +343,12 @@ video and audio streams from a DVD.")
(synopsis "SVT HEVC encoder")
(description "Scalable Video Technology (SVT) is a software-based video
coding technology that is highly optimized for Intel's Xeon processors. Using
-the SVT-HEVC encoder, it is possible to spread video encoding processing across
-multiple Intel's Xeon processors to achieve a real advantage of processing
-efficiency.")
- (home-page "https://01.org/svt")
- ;; Specifically targets x86_64 Intel hardware.
+the SVT-HEVC encoder, it is possible to spread video encoding processing
+across multiple Intel's Xeon processors to achieve a real advantage of
+processing efficiency. Note that this package @emph{requires} the AVX2
+instruction, which means it will @emph{not} work on older x86_64 CPUs such as
+the Core 2 Duo.")
+ (home-page "https://github.com/OpenVisualCloud/SVT-HEVC/")
(supported-systems '("x86_64-linux"))
(license (license:non-copyleft "file:///LICENSE.md"))))