summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:04:06 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:07:12 +0200
commit6be8b104b6a51ccd8712a8bd2f09db553021bc3b (patch)
tree9495cb5b8d8f310e352f882a93b281f576ebc192
parent32c77411b49ae96d324595800715c4baa168c3a3 (diff)
gnu: Add texlive-unitconv.
* gnu/packages/tex.scm (texlive-unitconv): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 51dfa023f6..bdf8124ac5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -98996,6 +98996,27 @@ package is compiled with Lua/XeLaTeX and a good Unicode font which has the
small caps characters, e.g., Charis SIL.")
(license (list license:gpl3+ license:fdl1.3+))))
+(define-public texlive-unitconv
+ (package
+ (name "texlive-unitconv")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/lualatex/unitconv/"
+ "tex/lualatex/unitconv/")
+ (base32
+ "0z10w79cddldw1rm9xzsr610ydn9hczx7dfda9n8g6wlpwhal0ps")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/unitconv")
+ (synopsis "Convert a length into one with another unit")
+ (description
+ "This package defines two macros to convert a value with unit into one with
+another unit. Supported are all TeX related units, and also @samp{km} and
+@samp{m}. The output can be in scientific notation for large values. The
+package only works with LuaLaTeX.")
+ (license license:lppl1.3+)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar