summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:05:15 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:07:37 +0200
commitabb2ae4b83681977d08abe9ab963e71d0e79de89 (patch)
treecd112e1b46226d8ffc20294c815bdfaed5f517bc
parentbfc1f7228e90a69b641d00ca8c670df7b1868a12 (diff)
gnu: Add texlive-xkcdcolors.
* gnu/packages/tex.scm (texlive-xkcdcolors): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 639396762d..8793a3d417 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -100292,6 +100292,29 @@ continued fractions).
All computations are compatible with expansion-only context.")
(license license:lppl1.3c)))
+(define-public texlive-xkcdcolors
+ (package
+ (name "texlive-xkcdcolors")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/xkcdcolors/"
+ "tex/latex/xkcdcolors/")
+ (base32
+ "0fm8ipmx6nflm4mbjdcz1c3jqqbv9rca5myahgksjpis5w3mvsfd")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/xkcdcolors")
+ (synopsis "XKCD names of colors")
+ (description
+ "In the year 2010, Randall Munroe on posted a really funny and nice article on
+XKCD. He made a very curious experiment: showing colors to a lot of people
+and asking to name each one. Afterward, he processed the data and sorted the
+names for each color by popularity --- that means, how many people gave the
+same name to the same color. This package makes the collected color names
+usable with LaTeX.")
+ (license (list license:lppl1.3c license:cc0))))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar