summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:05:18 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:07:38 +0200
commitadc8f7f7d190afdbe888ca1d74050a2107d9582d (patch)
tree54cd434b2f7092fc2476d7ff10d1b8ca26d67a4b
parent237d99349ee4025e00d3ffdd8c3e28638d46aa28 (diff)
gnu: Add texlive-xnewcommand.
* gnu/packages/tex.scm (texlive-xnewcommand): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ecb8f9fcbd..e5a2c3a20e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -100336,6 +100336,27 @@ a combination of @code{longtable} and @code{tabularx}: Header/footer
definitions, X-column specifier, and with possible pagebreaks.")
(license license:lppl1.3+)))
+(define-public texlive-xnewcommand
+ (package
+ (name "texlive-xnewcommand")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/xnewcommand/"
+ "tex/latex/xnewcommand/")
+ (base32
+ "0nicb4v9mxkavsgns37ap9bhi5wc1aqlk82dcsvpysxps1rmmyk4")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/xnewcommand")
+ (synopsis
+ "Define @code{\\global} and @code{\\protected} commands with @code{\\newcommand}")
+ (description
+ "The package provides the means of defining @code{\\global} and (e-TeX)
+@code{\\protected} commands, within the framework of LaTeX's standard
+@code{\\newcommand}.")
+ (license license:lppl)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar