summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:05:11 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:07:35 +0200
commitce960fdd3b7388fc114afacc9c99acb6934a7904 (patch)
treed609a43c524dd11f8e7d3ff801956f7af570ff4e
parent017dd3eae7fb4e43614572127a6bd9af58d00b34 (diff)
gnu: Add texlive-xellipsis.
* gnu/packages/tex.scm (texlive-xellipsis): New variable.
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bfb7a475df..1ee9199486 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -100175,6 +100175,31 @@ templates, and program components for other languages (functions, classes,
procedures, etc.).")
(license license:lppl)))
+(define-public texlive-xellipsis
+ (package
+ (name "texlive-xellipsis")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/xellipsis/"
+ "source/latex/xellipsis/"
+ "tex/latex/xellipsis/")
+ (base32
+ "1p1xzaprrglliid7zsl4s22zzqd7wrryhn69mdpac267jh8cpxds")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/xellipsis")
+ (synopsis
+ "Extremely configurable ellipses with formats for various style manuals")
+ (description
+ "The @code{xellipsis} package provides a system for configuring (almomst)
+every possible aspect of ellipses, including preceding and proceeding
+characters; the character itself; distances before and after each of these;
+and number of characters. It comes with both a compatibility option for
+standard LaTeX @code{\\ldots} as well as preset package options for the
+@emph{Chicago Manual of Style} (Turabian); the Bluebook; and MLA guidelines.")
+ (license license:lppl1.3+)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar