summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:04:09 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:07:14 +0200
commite55ad00666342f8d52e86a190dd98c3e19622ab4 (patch)
tree837ead0634631c94cab6d4487860ea3221f67098
parentddbd50a30ea087202149fa4eb9479484103e6ac8 (diff)
gnu: Add texlive-uri.
* gnu/packages/tex.scm (texlive-uri): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index dd886ee39f..376bd2f9c4 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -99061,6 +99061,27 @@ document authors, document validators, specification description, task
management, and several helping macros.")
(license license:lgpl3)))
+(define-public texlive-uri
+ (package
+ (name "texlive-uri")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/uri/" "source/latex/uri/"
+ "tex/latex/uri/")
+ (base32
+ "1vljxmd8fp5jfh8z223z2hh9rl40kiscvsp9y49k0677a1qk8yhq")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/uri")
+ (synopsis "Hyperlinks for a wide range of URIs")
+ (description
+ "The package provides automatic hyperlinks for URIs of type arXiv, ASIN,
+DOI, HDL, NBN, OCLC, OID, PubMed, TINY, TINY with preview, and WebCite. It
+provides commands @code{\\citeurl}, @code{\\mailto}, @code{\\ukoeln}, and
+@code{\\uref}.")
+ (license license:lppl1.3c)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar