summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:05:12 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:07:36 +0200
commitf40f001f5e9bb2f06ff35449c78259251daf20f7 (patch)
tree0e0c10b8d89a23dabe4d99f4ea6e027f9471bdfe
parentce960fdd3b7388fc114afacc9c99acb6934a7904 (diff)
gnu: Add texlive-xfakebold.
* gnu/packages/tex.scm (texlive-xfakebold): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1ee9199486..797b5697ec 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -100200,6 +100200,27 @@ standard LaTeX @code{\\ldots} as well as preset package options for the
@emph{Chicago Manual of Style} (Turabian); the Bluebook; and MLA guidelines.")
(license license:lppl1.3+)))
+(define-public texlive-xfakebold
+ (package
+ (name "texlive-xfakebold")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/xfakebold/"
+ "tex/latex/xfakebold/")
+ (base32
+ "0p51bscpac1vaxpqpwd9fdkxa1gv8f5x640zzzp09yhcbmpync8f")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs (list texlive-iftex))
+ (home-page "https://ctan.org/pkg/xfakebold")
+ (synopsis "Fake a regular font for bold characters")
+ (description
+ "This package uses PDF's text rendering to modify the linewidth of an outline
+font to get bold characters. It works only for vectorfonts where the glyphs
+are defined by their outline.")
+ (license license:lppl1.3c)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar