summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2022-07-03 20:00:48 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2022-07-03 20:36:47 +0200
commit13cc3da6b6d7d5d5a02dfe79c6d180d2ce197751 (patch)
tree4863840ba52bcec93ef05507a66603e37107cf71
parent9cdfecc8a3deaacaf39780ddfa6207a769409af6 (diff)
gnu: libfixposix: Add C_INCLUDE_PATH to the native-search-paths.
* gnu/packages/c.scm (libfixposix)[native-search-paths]: Add C_INCLUDE_PATH. This fixes the loading of cl-iolib among others.
-rw-r--r--gnu/packages/c.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 327f41589d..5265a15adc 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -306,6 +306,11 @@ Its three main components are:
(build-system gnu-build-system)
(native-inputs
(list autoconf automake libtool pkg-config check))
+ (native-search-paths
+ (list
+ (search-path-specification
+ (variable "C_INCLUDE_PATH")
+ (files '("include")))))
(synopsis "Thin wrapper over POSIX syscalls")
(description
"The purpose of libfixposix is to offer replacements for parts of POSIX