summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-07-03 16:59:59 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-07-03 17:07:09 +0200
commit65c9ecce2aa3eb393534c204023a28818ddbfe6c (patch)
treedbdd44d13986c51640f61b639abcb91b739b81c9
parent4cd5f030880882a22f4676101ae2c98bd8932b18 (diff)
gnu: python-renpy: Update to 8.0.0.
* gnu/packages/game-development.scm (python-renpy): Update to 8.0.0. [source]: Revert back to url-fetch. Also patch module/setup.py to not refer to missing sources.
-rw-r--r--gnu/packages/game-development.scm20
1 files changed, 9 insertions, 11 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 117c743107..07402aecf2 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1258,21 +1258,16 @@ While it aims to be used as a drop-in replacement, it appears to be
developed mainly for Ren'py.")
(license (list license:lgpl2.1 license:zlib)))))
-;; Using nightly from 2022-06-16.
-;; Revert back to URLs once renpy 8 is released!
-(define %renpy-commit "3e854bc7cb1642ca18b061a0c6e349f168965c43")
(define-public python-renpy
(package
(name "python-renpy")
- (version (git-version "7.99.99" "0" %renpy-commit))
+ (version "8.0.0")
(source
(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/renpy/renpy")
- (commit %renpy-commit)))
- (file-name (git-file-name name version))
- (sha256 (base32 "11g7hqhw4gbkx5ib2wsawrznmjbn8r9zkgf2sg39z56h96y8wfbn"))
+ (method url-fetch)
+ (uri (string-append "https://www.renpy.org/dl/" version
+ "/renpy-" version "-source.tar.bz2"))
+ (sha256 (base32 "09z3r16j4cxddkb50ghmi4xp0s05s15q4pzdmfajy85ignwqhjdi"))
(modules '((guix build utils)))
(patches
(search-patches
@@ -1281,7 +1276,10 @@ developed mainly for Ren'py.")
'(with-directory-excursion "module"
;; drop fribidi sources
(delete-file-recursively "fribidi-src")
- #t))))
+ ;; drop _renpytfd, as there are missing sources
+ (substitute* "setup.py"
+ (("cython\\(\"_renpytfd\"" all)
+ (string-append "pass # " all)))))))
(build-system python-build-system)
(arguments
`(#:tests? #f ; Ren'py doesn't seem to package tests