summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2022-07-03 20:34:44 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2022-07-03 20:36:48 +0200
commit875e803e60f8312898800d36e74ea0105cb6582c (patch)
tree7e52893f5ff4241cda6396b9ebbc2590994738b4
parent3a45cc634e69467e394bb1d70e0fd0a23f003965 (diff)
gnu: abcl: Update to 1.9.0.
* gnu/packages/java.scm (abcl): Update to 1.9.0. * gnu/packages/patches/abcl-fix-build-xml.patch: Update for 1.9.0.
-rw-r--r--gnu/packages/java.scm4
-rw-r--r--gnu/packages/patches/abcl-fix-build-xml.patch12
2 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 6113f1470a..14fef6986c 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -13711,7 +13711,7 @@ network protocols, and core version control algorithms.")
(define-public abcl
(package
(name "abcl")
- (version "1.8.0")
+ (version "1.9.0")
(source
(origin
(method url-fetch)
@@ -13719,7 +13719,7 @@ network protocols, and core version control algorithms.")
version "/abcl-src-" version ".tar.gz"))
(sha256
(base32
- "0zr5mmqyj484vza089l8vc88d07g0m8ymxzglvar3ydwyvi1x1qx"))
+ "0scqq5c7201xhp0g6i4y3m2nrk6l5any1nisiscbsd48ya25qax1"))
(patches
(search-patches
"abcl-fix-build-xml.patch"))))
diff --git a/gnu/packages/patches/abcl-fix-build-xml.patch b/gnu/packages/patches/abcl-fix-build-xml.patch
index dd315b4271..12f5cd4510 100644
--- a/gnu/packages/patches/abcl-fix-build-xml.patch
+++ b/gnu/packages/patches/abcl-fix-build-xml.patch
@@ -8,7 +8,7 @@ it non-deterministic.
--- a/build.xml
+++ b/build.xml
-@@ -327,7 +327,7 @@ from ${abcl.home.dir}
+@@ -338,7 +338,7 @@ from ${abcl.home.dir}
<property name="abcl.build.path"
value="${build.classes.dir}/org/armedbear/lisp/build"/>
<target name="abcl.stamp"
@@ -17,10 +17,10 @@ it non-deterministic.
<mkdir dir="${abcl.build.path}/.."/>
<loadfile property="abcl.version"
srcFile="${abcl.version.path}"/>
-@@ -455,11 +455,6 @@ from ${abcl.home.dir}
+@@ -479,11 +479,6 @@ Mercurial and Git.
value="${abcl.version}-${abcl.version.src}"/>
</target>
-
+
- <target name="abcl.stamp.hostname" if="unix">
- <exec executable="hostname" outputproperty="abcl.hostname"/>
- <echo>abcl.hostname: ${abcl.hostname}</echo>
@@ -29,16 +29,16 @@ it non-deterministic.
<target name="abcl.system.uptodate">
<condition property="abcl.system.needs-update.p">
<and>
-@@ -500,8 +495,6 @@ from ${abcl.home.dir}
+@@ -524,8 +519,6 @@ Mercurial and Git.
value="ABCL"/>
<attribute name="Implementation-Version"
- value="${abcl.implementation.version}"/>
+ value="${abcl.version}"/>
- <attribute name="Implementation-Build"
- value="${build}"/>
</section>
</manifest>
<metainf dir="${src.dir}/META-INF">
-@@ -1019,8 +1012,7 @@ ${basedir}/../cl-bench
+@@ -1050,8 +1043,7 @@ ${basedir}/../cl-bench
</unzip>
</target>