summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormuradm <mail@muradm.net>2022-06-20 07:22:37 +0300
committerLudovic Courtès <ludo@gnu.org>2022-07-03 01:41:06 +0200
commit9b6226bcdad4b3575431cd940db5039ef9bac315 (patch)
treec9ae204e0f021d5cea49bdfbd63904cebed42fe1
parente7ab3d33aec3993737cdbc4396a9c44a54a3ce84 (diff)
gnu: Add go-github-com-gorilla-websocket 1.5.0.
* gnu/packages/golang.scm (go-github-com-gorilla-websocket): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/golang.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 296f0b8b07..87a745e87f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -34,6 +34,7 @@
;;; Copyright © 2021 Philip McGrath <philip@philipmcgrath.com>
;;; Copyright © 2021 Lu Hui <luhux76@gmail.com>
;;; Copyright © 2022 Pier-Hugues Pellerin <phpellerin@gmail.com>
+;;; Copyright © 2022 muradm <mail@muradm.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -9843,3 +9844,24 @@ Jsonnet} data templating language in Go. It is a feature-complete,
production-ready implementation, compatible with the original Jsonnet C++
implementation.")
(license license:asl2.0)))
+
+(define-public go-github-com-gorilla-websocket
+ (package
+ (name "go-github-com-gorilla-websocket")
+ (version "1.5.0")
+ (home-page "https://github.com/gorilla/websocket")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1xrr6snvs9g1nzxxg05w4i4pq6k1xjljl5mvavd838qc468n118i"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/gorilla/websocket"))
+ (synopsis "Fast WebSocket implementation for Go")
+ (description "Gorilla WebSocket is a Go implementation of the WebSocket protocol.")
+ (license license:bsd-2)))