summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorr0man <roman@burningswell.com>2022-06-25 12:10:00 +0200
committerLudovic Courtès <ludo@gnu.org>2022-07-03 16:04:23 +0200
commitb4815e570d90239f06f2d6cdebee125d5efb1809 (patch)
treebc3dc69365ff4a7b4a145df1fb21d56cb46f1362
parent486251d4400fead42c3570ad63d98a10786e8dbb (diff)
gnu: Add Climate Data Operators.
* gnu/packages/geo.scm (cdo): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/geo.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 2e737373a8..d8e642f349 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -46,6 +46,7 @@
#:use-module (guix build-system qt)
#:use-module (guix build-system scons)
#:use-module (guix build-system r)
+ #:use-module (guix gexp)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix svn-download)
@@ -121,6 +122,35 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg))
+(define-public cdo
+ (package
+ (name "cdo")
+ (version "2.0.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://code.mpimet.mpg.de/attachments/download/26823/cdo-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1khdbd5cmnn7qm6hcqg4md5wbq14fs6brrns8b3g18diqgqvpvpd"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:configure-flags
+ #~(list (string-append "--with-netcdf="
+ #$(this-package-input "netcdf")))))
+ (inputs
+ (list netcdf))
+ (native-inputs
+ (list pkg-config))
+ (home-page "https://code.mpimet.mpg.de/projects/cdo")
+ (synopsis "Climate data operators")
+ (description "@acronym{CDO, Climate Data Operators} is a collection of command-line
+operators to manipulate and analyse climate and NWP model data. Supported
+data formats are GRIB 1/2, netCDF 3/4, SERVICE, EXTRA and IEG. There are more
+than 600 operators available.")
+ (license license:bsd-3)))
+
(define-public memphis
(package
(name "memphis")