summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2022-07-03 13:45:59 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2022-07-03 14:21:02 +0200
commitbee129a806a9af0cc137603e11ef40e24f24f663 (patch)
tree6dff2173704b90aab319ef338191e58228a5ff30
parent4eaf90470f466b3fdab87f6961cb18bb348d433f (diff)
gnu: sbcl-fof: Also build the fof/mf subsystem.
* gnu/packages/lisp-xyz.scm (sbcl-fof)[arguments]: Also build the fof/mf subsystem. [inputs]: Add sbcl-cl-json.
-rw-r--r--gnu/packages/lisp-xyz.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 22730cf4ce..76be403bc2 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -15437,7 +15437,8 @@ return the CPU count of the current system.")
(base32 "0ipy51q2fw03xk9rqcyzbq2b9c32npc1gl3c53rdjywpak7zwwg6"))))
(build-system asdf-build-system/sbcl)
(arguments
- `(#:phases
+ `(#:asd-systems '("fof" "fof/mf")
+ #:phases
(modify-phases %standard-phases
(add-after 'unpack 'fix-paths
(lambda* (#:key inputs #:allow-other-keys)
@@ -15447,6 +15448,7 @@ return the CPU count of the current system.")
(assoc-ref inputs "ffmpeg")))))))))
(inputs
(list sbcl-alexandria
+ sbcl-cl-json
sbcl-cl-str
sbcl-hu.dwim.defclass-star
sbcl-local-time