summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-01-13 15:06:02 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-01-14 11:41:19 +0200
commita275ef39663e36259020003694ea27d03797e69c (patch)
tree010cb6d13dd2865da6f7703990f195efd06a676b
parent720baa1e0b64895b83bfc3c2aeed8c52e9000498 (diff)
gnu: earlyoom: Only build with pandoc on certain systems.
* gnu/packages/linux.scm (earlyoom)[native-inputs]: Only use pandoc on x86_64-linux and i686-linux.
-rw-r--r--gnu/packages/linux.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 46645e98b4..7b12cb8ec1 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3756,12 +3756,15 @@ from the module-init-tools project.")
"GO111MODULE=off")
#:test-target "test"))
(native-inputs
- (list
- ;; For the test suite.
- cppcheck
- go
+ (append
;; To generate the manpage.
- pandoc))
+ (if (or (target-x86-64?) (target-x86-32?))
+ (list pandoc)
+ '())
+ (list
+ ;; For the test suite.
+ cppcheck
+ go)))
(home-page "https://github.com/rfjakob/earlyoom")
(synopsis "Simple out of memory (OOM) daemon for the Linux kernel")
(description "Early OOM is a minimalist out of memory (OOM) daemon that