summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-05-22 16:58:15 +0200
committerJakub Kądziołka <kuba@kadziolka.net>2020-06-07 22:10:31 +0200
commit0601fb29fbfe353714ba596363be8a2f80151398 (patch)
treeec7845ecd62289b3d73cced3fe34263afa72e552
parentfae75ff9911b91a8c5ec257335c7ebed04c82929 (diff)
gnu: Add go-github-com-stretchr-objx.
* gnu/packages/golang.scm (go-github-com-stretchr-objx): New variable.
-rw-r--r--gnu/packages/golang.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ae0b7c6779..ca06790032 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -917,6 +917,29 @@ increment versions.")
Go.")
(license license:expat))))
+(define-public go-github-com-stretchr-objx
+ (package
+ (name "go-github-com-stretchr-objx")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/stretchr/objx.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0pcdvakxgddaiwcdj73ra4da05a3q4cgwbpm2w75ycq4kzv8ij8k"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/stretchr/objx"))
+ (home-page "https://github.com/stretchr/objx")
+ (synopsis "Go package for dealing with maps, slices, JSON and other data")
+ (description "This package provides a Go library for dealing with maps,
+slices, JSON and other data.")
+ (license license:expat)))
+
(define-public go-github-com-stretchr-testify
(let ((commit
"b1f989447a57594c728884458a39abf3a73447f7")