summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2020-06-07 23:49:55 -0400
committerBrice Waegeneire <brice@waegenei.re>2020-06-08 10:12:51 +0200
commit1acf4c59f8bd47002328307ea04b53864b3f2c33 (patch)
tree9bc9e103a81587afe03249dbb6647c6d5a2f81d4
parentfa122ac4ca2bd4c87b216e2f478397bcde2c1d8f (diff)
gnu: Add v4l2loopback-linux-module.
* gnu/packages/linux.scm (v4l2loopback-linux-module): New variable.
-rw-r--r--gnu/packages/linux.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index ab19a16bce..a31f3d81ca 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -43,6 +43,7 @@
;;; Copyright © 2020 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1134,6 +1135,39 @@ module allows the control of the backlight level or luminance property when
supported under @file{/sys/class/backlight/}.")
(license license:gpl2+)))
+(define-public v4l2loopback-linux-module
+ (package
+ (name "v4l2loopback-linux-module")
+ (version "0.12.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/umlaeute/v4l2loopback.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1qi4l6yam8nrlmc3zwkrz9vph0xsj1cgmkqci4652mbpbzigg7vn"))))
+ (build-system linux-module-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "make"
+ "--directory=./tests"
+ (string-append "CC=" ,(cc-for-target))))))))
+ (home-page "https://github.com/umlaeute/v4l2loopback")
+ (synopsis "Linux kernel module that allows you to create \"virtual video devices\"")
+ (description "This module allows you to create \"virtual video devices\"
+normal (v4l2) applications will read these devices as if they were ordinary
+video devices, but the video will not be read from e.g. a capture card but
+instead it is generated by another application. this allows you for instance
+to apply some nifty video effects on your Jitsi video... it also allows some
+more serious things (e.g. using it to add streaming capabilities to an
+application by the means of hooking GStreamer into the loopback devices).")
+ (license license:gpl2+)))
+
;;;
;;; Pluggable authentication modules (PAM).