summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan (janneke) Nieuwenhuizen <janneke@gnu.org>2020-06-08 15:03:05 +0200
committerJan Nieuwenhuizen <janneke@gnu.org>2020-06-08 16:50:40 +0200
commit4a6974667e838c82ae375c8b9c1b3eaca7a72ac4 (patch)
treeacd5f99377193515c133d0e566adb947ba101f0e
parent8176ce6fde681a94558cf4be129fa1f385010664 (diff)
gnu: openssh: Remove exception to build without xauth for the Hurd.
* gnu/packages/ssh.scm (openssh)[inputs]: Unconditionally include xauth; for the Hurd: use openssh-sans-x for now.
-rw-r--r--gnu/packages/ssh.scm5
1 files changed, 1 insertions, 4 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 43764a8245..d42971d4f0 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -43,7 +43,6 @@
#:use-module (gnu packages groff)
#:use-module (gnu packages guile)
#:use-module (gnu packages libedit)
- #:use-module (gnu packages hurd)
#:use-module (gnu packages linux)
#:use-module (gnu packages logging)
#:use-module (gnu packages m4)
@@ -150,9 +149,7 @@ a server that supports the SSH-2 protocol.")
("pam" ,linux-pam)
("mit-krb5" ,mit-krb5)
("zlib" ,zlib)
- ,@(if (hurd-target?)
- '()
- `(("xauth" ,xauth))))) ; for 'ssh -X' and 'ssh -Y'
+ ("xauth" ,xauth))) ; for 'ssh -X' and 'ssh -Y'
(arguments
`(#:test-target "tests"
;; Otherwise, the test scripts try to use a nonexistent directory and