summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2020-06-06 11:10:34 +0200
committerMathieu Othacehe <othacehe@gnu.org>2020-06-08 11:02:43 +0200
commit65c8512f9c709a85766e0e1cb8eee12459a3d705 (patch)
tree1f378b26e7bd061f8b99d39b0a370ddaa8b195bb
parent173d22a1c03450c804b2c7fab1393670fef45606 (diff)
gnu: Add openssh-sans-x.
* gnu/packages/ssh.scm (openssh-sans-x): New variable.
-rw-r--r--gnu/packages/ssh.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 73841db6b5..43764a8245 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -239,6 +239,15 @@ Additionally, various channel-specific options can be negotiated.")
"See LICENSE in the distribution."))
(home-page "https://www.openssh.com/")))
+;; OpenSSH without X support. This allows to use OpenSSH without dragging X
+;; libraries to the closure.
+(define-public openssh-sans-x
+ (package
+ (inherit openssh)
+ (name "openssh-sans-x")
+ (inputs (alist-delete "xauth" (package-inputs openssh)))
+ (synopsis "OpenSSH client and server without X11 support")))
+
(define-public guile-ssh
(package
(name "guile-ssh")