summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-05-22 17:01:59 +0200
committerJakub Kądziołka <kuba@kadziolka.net>2020-06-07 22:10:32 +0200
commit715f589ea39146fa66cce5470c0368073c471540 (patch)
tree5ee290db7fca3389607a4323d1590b2e12458e13
parent388ffbfbfef1e279e5bc36d1fdd2bb185387dbd1 (diff)
gnu: go-github-com-stretchr-testify: Update to 1.5.1.
* gnu/packages/golang.scm (go-github-com-stretchr-testify): Update to 1.5.1.
-rw-r--r--gnu/packages/golang.scm48
1 files changed, 25 insertions, 23 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a35b21e4b5..d95e195ba5 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -941,28 +941,30 @@ slices, JSON and other data.")
(license license:expat)))
(define-public go-github-com-stretchr-testify
- (let ((commit
- "b1f989447a57594c728884458a39abf3a73447f7")
- (revision "0"))
- (package
- (name "go-github-com-stretchr-testify")
- (version (git-version "1.1.4" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/stretchr/testify.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0p0gkqzh2p8r5g0rxm885ljl7ghih7h7hx9w562imx5ka0vdgixv"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/stretchr/testify"))
- (home-page "https://github.com/stretchr/testify")
- (synopsis "Go helper library for tests and invariant checking")
- (description "This package provide many tools for testifying that your
+ (package
+ (name "go-github-com-stretchr-testify")
+ (version "1.5.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/stretchr/testify.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "09r89m1wy4cjv2nps1ykp00qjpi0531r07q3s34hr7m6njk4srkl"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/stretchr/testify"))
+ (propagated-inputs
+ `(("github.com/davecgh/go-spew" ,go-github-com-davecgh-go-spew)
+ ("github.com/pmezard/go-difflib" ,go-github-com-pmezard-go-difflib)
+ ("github.com/stretchr/objx" ,go-github-com-stretchr-objx)
+ ("gopkg.in/yaml.v2" ,go-gopkg-in-yaml-v2)))
+ (home-page "https://github.com/stretchr/testify")
+ (synopsis "Go helper library for tests and invariant checking")
+ (description "This package provide many tools for testifying that your
code will behave as you intend.
Features include:
@@ -972,7 +974,7 @@ Features include:
@item HTTP response trapping
@item Testing suite interfaces and functions.
@end itemize")
- (license license:expat))))
+ (license license:expat)))
(define-public go-github-com-tevino-abool
(let ((commit