summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Prior <rprior@protonmail.com>2020-06-03 03:06:35 +0000
committerEfraim Flashner <efraim@flashner.co.il>2020-06-07 18:17:34 +0300
commit8d7efc7a950968a73c90bb64af9a431c68781c55 (patch)
tree954e1bd95b457f304a1ca821f5ce411b66daf3a2
parent2dcaa7601f8709e2761df7a2a2bcd9eeeb10dcb6 (diff)
gnu: Add vala-language-server.
* gnu/packages/gnome-xyz.scm (vala-language-server): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/gnome-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 83e37f97b0..21838ff0cd 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -585,3 +586,36 @@ dark elements. It supports GNOME, Unity, Xfce, and Openbox.")
(description "Papirus is a fork of the icon theme Paper with a lot of new icons
and a few extra features.")
(license license:gpl3))))
+
+(define-public vala-language-server
+ (package
+ (name "vala-language-server")
+ ;; Note to maintainer: VLS must be built with a Vala toolchain the same
+ ;; version or newer. Therefore when you update this package you may need
+ ;; to update Vala too.
+ (version "0.48")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/benwaffle/vala-language-server.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0chgfpci247skrvsiq1l8cas8sj2z6z42dlarka3df3qwxmh0if0"))))
+ (build-system meson-build-system)
+ (arguments '(#:glib-or-gtk? #t))
+ (inputs
+ `(("glib" ,glib)
+ ("json-glib" ,json-glib)
+ ("jsonrpc-glib" ,jsonrpc-glib)
+ ("libgee" ,libgee)
+ ("vala" ,vala-0.48)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/benwaffle/vala-language-server")
+ (synopsis "Language server for Vala")
+ (description "The Vala language server is an implementation of the Vala
+language specification for the Language Server Protocol (LSP). This tool is
+used in text editing environments to provide a complete and integrated
+feature-set for programming Vala effectively.")
+ (license license:lgpl2.1+)))