summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-06-08 08:53:07 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-06-08 10:36:50 +0200
commitd1fe14be6a98bf8dec63bbee7ac82cd9fadc90f5 (patch)
tree515b23c1b67290b382375051fe7e8a50147ae569
parentde728cb859738b9f2ec977a09338f9c73656637a (diff)
gnu: rtl8821ce-linux-module: Use MAKE-FLAGS.
* gnu/packages/linux.scm (rtl8821ce-linux-module)[arguments]: Use MAKE-FLAGS keyword. Make CC environment variable a make flag.
-rw-r--r--gnu/packages/linux.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c78f2fe533..329bf7c327 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1051,16 +1051,17 @@ RTL8812AU, RTL8821AU, and RTL8814AU chips.")
"17jiw25k74kv5lnvgycvj2g1n06hbrpjz6p4znk4a62g136rhn4s"))))
(build-system linux-module-build-system)
(arguments
- `(#:phases
+ `(#:make-flags
+ (list "CC=gcc"
+ (string-append "KSRC="
+ (assoc-ref %build-inputs "linux-module-builder")
+ "/lib/modules/build"))
+ #:phases
(modify-phases %standard-phases
(replace 'build
- (lambda* (#:key (make-flags '()) inputs #:allow-other-keys)
- (setenv "CC" "gcc")
- (invoke "make"
- (string-append "KSRC="
- (assoc-ref inputs "linux-module-builder")
- "/lib/modules/build")))))
- #:tests? #f))
+ (lambda* (#:key (make-flags '()) #:allow-other-keys)
+ (apply invoke "make" make-flags))))
+ #:tests? #f)) ; no test suite
(home-page "https://github.com/tomaspinho/rtl8821ce")
(synopsis "Linux driver for Realtek RTL8821CE wireless network adapters")
(description "This is Realtek's RTL8821CE Linux driver for wireless