summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-06-08 08:46:25 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-06-08 10:36:50 +0200
commitde728cb859738b9f2ec977a09338f9c73656637a (patch)
tree20e03c14eb9fe02d798494a4f167ce0452ef4df4
parent44adf883f082eaa4881a698de0d49b7b692972f0 (diff)
gnu: rtl8812au-aircrack-ng-linux-module: Use MAKE-FLAGS.
* gnu/packages/linux.scm (rtl8812au-aircrack-ng-linux-module) [arguments]: Use MAKE-FLAGS keyword.
-rw-r--r--gnu/packages/linux.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 67449c02d2..c78f2fe533 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1013,15 +1013,15 @@ and should be used with caution, especially on untested models.")
#t))))
(build-system linux-module-build-system)
(arguments
- `(#:phases
+ `(#:make-flags
+ (list (string-append "KSRC="
+ (assoc-ref %build-inputs "linux-module-builder")
+ "/lib/modules/build"))
+ #:phases
(modify-phases %standard-phases
(replace 'build
- (lambda* (#:key inputs make-flags #:allow-other-keys)
- (apply invoke "make"
- (string-append "KSRC="
- (assoc-ref inputs "linux-module-builder")
- "/lib/modules/build")
- (or make-flags '())))))
+ (lambda* (#:key (make-flags '()) #:allow-other-keys)
+ (apply invoke "make" make-flags))))
#:tests? #f)) ; no test suite
(supported-systems '("x86_64-linux" "i686-linux"))
(home-page "https://github.com/aircrack-ng/rtl8812au")