summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-06-07 18:46:42 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-06-07 22:27:40 +0300
commitfae75ff9911b91a8c5ec257335c7ebed04c82929 (patch)
treebedfa7afe1f6b25fc6c57e2e88dde2df8210c740
parent9b5e7d01afc0ca295ccba231b002f5314f5ef9bd (diff)
gnu: Add epour.
* gnu/packages/enlightenment.scm (epour): New variable.
-rw-r--r--gnu/packages/enlightenment.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index d852cbb275..40f1191416 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -33,6 +33,7 @@
#:use-module (gnu packages algebra)
#:use-module (gnu packages avahi)
#:use-module (gnu packages bash)
+ #:use-module (gnu packages bittorrent)
#:use-module (gnu packages check)
#:use-module (gnu packages code)
#:use-module (gnu packages compression)
@@ -598,3 +599,42 @@ directories.
"This is a process monitor and system monitor using the
@dfn{Enlightenment Foundation Libraries} (EFL).")
(license license:bsd-2)))
+
+(define-public epour
+ (package
+ (name "epour")
+ (version "0.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://download.enlightenment.org/rel/apps/epour"
+ "/epour-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0g9f9p01hsq6dcf4cs1pwq95g6fpkyjgwqlvdjk1km1i5gj5ygqw"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f ; no test target
+ #:use-setuptools? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'find-theme-dir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "epour/gui/__init__.py"
+ (("join\\(data_path")
+ (string-append "join(\"" out "/share/epour\"")))
+ #t))))))
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("python-distutils-extra" ,python-distutils-extra)))
+ (inputs
+ `(("libtorrent-rasterbar" ,libtorrent-rasterbar)
+ ("python-dbus" ,python-dbus)
+ ("python-efl" ,python-efl)
+ ("python-pyxdg" ,python-pyxdg)))
+ (home-page "https://www.enlightenment.org")
+ (synopsis "EFL Bittorrent client")
+ (description "Epour is a BitTorrent client based on the @dfn{Enlightenment
+Foundation Libraries} (EFL) and rb-libtorrent.")
+ (license license:gpl3+)))