summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-18 19:45:46 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-18 20:13:42 +0100
commit1ac187216136e7a1f0cfcbf76e664091f5d1ff26 (patch)
treee6a7098dc8f1068ce86b9cde4f5a7edaf140b33f
parentc06bf6a3e2bfc9143ca95f04aeed10a5ed565aaf (diff)
gnu: lvm2: Remove obsolete phase.
* gnu/packages/linux.scm (lvm2)[arguments]: Remove MAKE-OBJECTS-WRITABLE-PHASE.
-rw-r--r--gnu/packages/linux.scm12
1 files changed, 1 insertions, 11 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index ecdfca59a1..3a553fc96b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2077,17 +2077,7 @@ time.")
;; Replace /bin/sh with the right file name.
(patch-makefile-SHELL "make.tmpl")
- #t))
- (add-before 'strip 'make-objects-writable
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Make compiled objects writable so they can be stripped.
- (let ((out (assoc-ref outputs "out")))
- (for-each (lambda (file)
- (chmod file #o755))
- (append
- (find-files (string-append out "/lib"))
- (find-files (string-append out "/sbin"))))
- #t))))
+ #t)))
#:configure-flags (list (string-append "--sysconfdir="
(assoc-ref %outputs "out")