summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-03-07 19:52:40 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-05-15 22:00:06 +0200
commit3a068b4307a24015254d2ea8e99d9b677ae8fb75 (patch)
treed5e78614321b73ac4345c4e43bc15bcb285ba58a
parent4f4d2e470ddd72d0a96c4b5a40d9874ee9256a2e (diff)
gnu: Add java-httpcomponents-httpcore-nio.
* gnu/packages/java.scm (java-httpcomponents-httpcore-nio): New variable.
-rw-r--r--gnu/packages/java.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index ee7d7d4af2..032f58a587 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2073,6 +2073,28 @@ NIO.
This package provides the blocking I/O model library.")
(license license:asl2.0)))
+(define-public java-httpcomponents-httpcore-nio
+ (package (inherit java-httpcomponents-httpcore)
+ (name "java-httpcomponents-httpcore-nio")
+ (arguments
+ `(#:jar-name "httpcomponents-httpcore-nio.jar"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "httpcore-nio") #t)))))
+ (inputs
+ `(("java-httpcomponents-httpcore" ,java-httpcomponents-httpcore)
+ ("java-hamcrest-core" ,java-hamcrest-core)
+ ,@(package-inputs java-httpcomponents-httpcore)))
+ (description "HttpCore is a set of low level HTTP transport components
+that can be used to build custom client and server side HTTP services with a
+minimal footprint. HttpCore supports two I/O models: blocking I/O model based
+on the classic Java I/O and non-blocking, event driven I/O model based on Java
+NIO.
+
+This package provides the non-blocking I/O model library based on Java
+NIO.")))
+
(define-public java-commons-cli
(package
(name "java-commons-cli")