summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-09-05 14:46:33 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-09-05 20:03:05 +0200
commit4f8247b54b4bb95fc58b3c4f0c30d635909496e2 (patch)
treeb08723f5e2676fb489d444a26dcc40dc3407ff1b
parent1ec1989f8007d0b90cc3b5ac379bb2f7133e299f (diff)
gnu: Add r-pkgbuild.
* gnu/packages/cran.scm (r-pkgbuild): New variable.
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 2082378aae..ae51844dab 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -499,6 +499,33 @@ print, summary, plot, update, etc.
processes. Most of its code is based on the @code{psutil} Python package.")
(license license:bsd-3)))
+(define-public r-pkgbuild
+ (package
+ (name "r-pkgbuild")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "pkgbuild" version))
+ (sha256
+ (base32
+ "10iz8057mixl9j73pq2cbp4ib6dadfsgi3fcsjjm7l3wwb9issd9"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-callr" ,r-callr)
+ ("r-crayon" ,r-crayon)
+ ("r-desc" ,r-desc)
+ ("r-r6" ,r-r6)
+ ("r-rprojroot" ,r-rprojroot)
+ ("r-withr" ,r-withr)))
+ (home-page "https://github.com/r-pkgs/pkgbuild")
+ (synopsis "Find tools needed to build R packages")
+ (description
+ "This package provides functions used to build R packages. It locates
+compilers needed to build R packages on various platforms and ensures the PATH
+is configured appropriately so R can use them.")
+ (license license:gpl3)))
+
(define-public r-rcpp
(package
(name "r-rcpp")