summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2018-10-08 21:42:28 +0800
committer宋文武 <iyzsong@member.fsf.org>2018-10-12 22:23:58 +0800
commit6826f1e1ede0526dd1247546aa5ec195bacd5cc5 (patch)
tree863111671d11fbfffbeb359bb6af42ce50a1702d
parent8036b0942b89022147aaf9cd9940988fdbcc19ef (diff)
gnu: Add libpd.
* gnu/packages/music.scm (libpd): New variable.
-rw-r--r--gnu/packages/music.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index e1bac6f51e..13a6ecc36f 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1777,6 +1777,42 @@ programming methods as well as for realizing complex systems for large-scale
projects.")
(license license:bsd-3)))
+(define-public libpd
+ (package
+ (name "libpd")
+ (version "0.11.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/libpd/libpd.git")
+ (commit version)
+ (recursive? #t))) ; for the 'pure-data' submodule
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1bcg1d9iyf9n37hwwphmih0c8rd1xcqykil5z1cax6xfs76552nk"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; no tests
+ #:make-flags '("CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; no configure script
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (invoke "make" "install"
+ (string-append "prefix=" out)
+ ;; XXX: Fix the last 2 lines of 'install' target.
+ "LIBPD_IMPLIB=NO"
+ "LIBPD_DEF=NO")))))))
+ (home-page "http://libpd.cc/")
+ (synopsis "Pure Data as an embeddable audio synthesis library")
+ (description
+ "Libpd provides Pure Data as an embeddable audio synthesis library. Its
+main purpose is to liberate raw audio rendering from audio and MIDI drivers.")
+ (license license:bsd-3)))
+
(define-public portmidi
(package
(name "portmidi")