summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2018-08-29 00:06:28 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2018-10-14 22:02:40 -0400
commitbb840999c8592b0077c78170e135b59bc79638ed (patch)
tree84f480d8a41484efb30ff1420955220668702f34
parent0731fc1ce7f397724708f4956e6bdeb9c01c6762 (diff)
gnu: Add python-falcon.
* gnu/packages/python-web.scm (python-falcon): New variable.
-rw-r--r--gnu/packages/python-web.scm54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 2a7487202a..77fb99dc56 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -26,6 +26,7 @@
;;; Copyright © 2018 Tomáš Čech <sleep_walker@gnu.org>
;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2018 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -127,6 +128,59 @@ asynchronous DNS resolutions with a synchronous looking interface by
using @url{https://github.com/saghul/pycares,pycares}.")
(license license:expat)))
+(define-public python-falcon
+ (package
+ (name "python-falcon")
+ (version "1.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "falcon" version))
+ (sha256
+ (base32
+ "1i0vmqsk24z4biirqhpvas9h28wy7nmpy3jvnb6rz2imq04zd09r"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "pytest"))))))
+ (propagated-inputs
+ `(("python-mimeparse" ,python-mimeparse)
+ ("python-six" ,python-six)))
+ (native-inputs
+ `(("python-cython" ,python-cython) ;for faster binaries
+ ("python-pytest" ,python-pytest)
+ ("python-pyyaml" ,python-pyyaml)
+ ("python-requests" ,python-requests)
+ ("python-testtools" ,python-testtools)
+ ("python-jsonschema" ,python-jsonschema)
+ ("python-msgpack" ,python-msgpack)))
+ (home-page "https://falconframework.org")
+ (synopsis
+ "Web framework for building APIs and application backends")
+ (description
+ "Falcon is a web API framework for building microservices, application
+backends and higher-level frameworks. Among its features are:
+@itemize
+@item Optimized and extensible code base
+@item Routing via URI templates and REST-inspired resource
+classes
+@item Access to headers and bodies through request and response
+classes
+@item Request processing via middleware components and hooks
+@item Idiomatic HTTP error responses
+@item Straightforward exception handling
+@item Unit testing support through WSGI helpers and mocks
+@item Compatible with both CPython and PyPy
+@item Cython support for better performance when used with CPython
+@end itemize")
+ (license license:asl2.0)))
+
+(define-public python2-falcon
+ (package-with-python2 python-falcon))
+
(define-public python-furl
(package
(name "python-furl")