summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-09-05 15:12:47 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-09-05 20:03:06 +0200
commitbfee9ce88f3c6bd49a1dfc003128d1cb3b7aa421 (patch)
treedfb4e59e64393dad72417315a2c303b8f1350e77
parentc183fa26881d363c2c078dad534c9098e05456cd (diff)
gnu: Add r-snakecase.
* gnu/packages/cran.scm (r-snakecase): New variable.
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index a7a42573ae..e26deabd6e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4691,6 +4691,28 @@ be added or removed. When working with Word documents, a cursor can be used
to help insert or delete content at a specific location in the document.")
(license license:gpl3)))
+(define-public r-snakecase
+ (package
+ (name "r-snakecase")
+ (version "0.9.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "snakecase" version))
+ (sha256
+ (base32
+ "1g6xai53dl24ws0mwhqrkcv583ziaq505cv3z8v5dhjgy98kilyj"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-stringi" ,r-stringi)
+ ("r-stringr" ,r-stringr)))
+ (home-page "https://github.com/Tazinho/snakecase")
+ (synopsis "Convert strings into any case")
+ (description
+ "This package provides a consistent, flexible and easy to use tool to
+parse and convert strings into cases like snake or camel among others.")
+ (license license:gpl3)))
+
(define-public r-writexl
(package
(name "r-writexl")