summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-09-05 15:14:17 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-09-05 20:03:06 +0200
commitcfc06314334933f0045e1851449722a612e28f5b (patch)
tree01c13ad81ede7a4554ee2229bd3b0707c6ca5bf3
parentde059e4bd3dce2937a4ac7853731f7f65e950475 (diff)
gnu: Add r-sjlabelled.
* gnu/packages/cran.scm (r-sjlabelled): New variable.
-rw-r--r--gnu/packages/cran.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 64156f5aa6..bf942f03f6 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4737,6 +4737,39 @@ from the @code{stats} package, as well as numerous other model classes from
other add-on packages.")
(license license:expat)))
+(define-public r-sjlabelled
+ (package
+ (name "r-sjlabelled")
+ (version "1.0.13")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "sjlabelled" version))
+ (sha256
+ (base32
+ "0xizj7mrhnbn8kwjgm076si9w68a7lgrx4vj1sbqmv9jx055h8wv"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-broom" ,r-broom)
+ ("r-dplyr" ,r-dplyr)
+ ("r-haven" ,r-haven)
+ ("r-magrittr" ,r-magrittr)
+ ("r-prediction" ,r-prediction)
+ ("r-purrr" ,r-purrr)
+ ("r-rlang" ,r-rlang)
+ ("r-snakecase" ,r-snakecase)
+ ("r-tibble" ,r-tibble)
+ ("r-tidyselect" ,r-tidyselect)))
+ (home-page "https://github.com/strengejacke/sjlabelled")
+ (synopsis "Labelled data utility functions")
+ (description
+ "This package provides a collection of functions dealing with labelled
+data, like reading and writing data between R and other statistical software
+packages. This includes easy ways to get, set or change value and variable
+label attributes, to convert labelled vectors into factors or numeric (and
+vice versa), or to deal with multiple declared missing values.")
+ (license license:gpl3)))
+
(define-public r-writexl
(package
(name "r-writexl")