summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-10-15 06:04:49 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-10-15 06:19:37 +0200
commitdfe05297f3922a0403a9d788bc4d87502e148d87 (patch)
tree684505a0ade195bcae9962d04811ad4d764933c4
parent4702d45280425f69f70cfb891ccacaf94cbd2790 (diff)
gnu: x265: Update to 2.9.
* gnu/packages/video.scm (x265): Update to 2.9. [source]: Remove x265-fix-ppc64le-build.patch. * gnu/packages/patches/x265-fix-ppc64le-build.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/x265-fix-ppc64le-build.patch25
-rw-r--r--gnu/packages/video.scm7
3 files changed, 3 insertions, 30 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index af3773c893..4c0485c04f 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1228,7 +1228,6 @@ dist_patch_DATA = \
%D%/packages/patches/wpa-supplicant-krack-followups.patch \
%D%/packages/patches/wxmaxima-do-not-use-old-gnuplot-parameters.patch \
%D%/packages/patches/x265-arm-asm-primitives.patch \
- %D%/packages/patches/x265-fix-ppc64le-build.patch \
%D%/packages/patches/xapian-revert-5489fb2f8.patch \
%D%/packages/patches/xboing-CVE-2004-0149.patch \
%D%/packages/patches/xf86-video-ark-remove-mibstore.patch \
diff --git a/gnu/packages/patches/x265-fix-ppc64le-build.patch b/gnu/packages/patches/x265-fix-ppc64le-build.patch
deleted file mode 100644
index f71d2436ab..0000000000
--- a/gnu/packages/patches/x265-fix-ppc64le-build.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-https://sources.debian.org/data/main/x/x265/2.8-3/debian/patches/0003-Fix-build-error-on-on-ppc64le.patch
-
-This patch also fixes building on armhf-linux and aarch64-linux
-
-From: Jayashree <jayashree.c@multicorewareinc.com>
-Date: Fri, 25 May 2018 10:26:05 +0530
-Subject: Fix build error on on ppc64le
-
----
- source/common/param.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/source/common/param.cpp b/source/common/param.cpp
-index 31bcbc7..4a6d0c8 100644
---- a/source/common/param.cpp
-+++ b/source/common/param.cpp
-@@ -633,7 +633,7 @@ int x265_param_parse(x265_param* p, const char* name, const char* value)
- if (bValueWasNull)
- p->cpuid = atobool(value);
- else
-- p->cpuid = parseCpuName(value, bError);
-+ p->cpuid = parseCpuName(value, bError, false);
- #endif
- }
- OPT("fps")
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 3e191ef6da..e281bf8fff 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -392,7 +392,7 @@ and creating Matroska files from other media files (@code{mkvmerge}).")
(define-public x265
(package
(name "x265")
- (version "2.8")
+ (version "2.9")
(source
(origin
(method url-fetch)
@@ -400,9 +400,8 @@ and creating Matroska files from other media files (@code{mkvmerge}).")
"x265_" version ".tar.gz"))
(sha256
(base32
- "0qx8mavwdzdpkkby7n29i9av7zsnklavacwfz537mf62q2pzjnbf"))
- (patches (search-patches "x265-fix-ppc64le-build.patch"
- "x265-arm-asm-primitives.patch"))
+ "090hp4216isis8q5gb7bwzia8rfyzni54z21jnwm97x3hiy6ibpb"))
+ (patches (search-patches "x265-arm-asm-primitives.patch"))
(modules '((guix build utils)))
(snippet '(begin
(delete-file-recursively "source/compat/getopt")