summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2017-10-31 14:10:37 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2017-10-31 14:10:37 +0300
commit2e4bb8c8173e9be80cb33f8ce53eb65a7f9ecafd (patch)
tree1df181e3de8bd0c7f444e8e8eb87d52f65b173e2
parent7bf59f702179173055853fa940ae72292cd65a4e (diff)
gnu: Add emacs-helm-make.
* gnu/packages/emacs.scm (emacs-helm-make): New variable.
-rw-r--r--gnu/packages/emacs.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 026b27bf8d..1278194f11 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -3896,6 +3896,33 @@ for search-based navigation of buffers.")
"This Emacs library provides a Helm interface for Projectile.")
(license license:gpl3+)))
+(define-public emacs-helm-make
+ (let ((commit "786104ac0c3cf4fe5b53f841eb9fe10bda2e4031")
+ (revision "1"))
+ (package
+ (name "emacs-helm-make")
+ (version (string-append "0.1.0-" revision "." (string-take commit 7)))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/abo-abo/helm-make.git")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0qdfk0p2j8jah7m0ngy2mm7775cn779m3a84yll86wqc74g331qs"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-helm" ,emacs-helm)
+ ("emacs-projectile" ,emacs-projectile)))
+ (home-page "https://github.com/abo-abo/helm-make")
+ (synopsis "Select a Makefile target with helm")
+ (description "@code{helm-make} or @code{helm-make-projectile} will give
+you a @code{helm} selection of directory Makefile's targets. Selecting a
+target will call @code{compile} on it.")
+ (license license:gpl3+))))
+
(define-public emacs-cider
(package
(name "emacs-cider")