summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-23 23:52:16 -0400
committerMark H Weaver <mhw@netris.org>2018-03-25 05:01:32 -0400
commit5114c83a24bd3d974ac740858c2091e24f93f269 (patch)
tree849d36b342219c9449537b6fc3d6b5b810b428fa
parent13f5a0dc80d02b89f46bbce21a7f8690a91a1155 (diff)
gnu: bdb: Use invoke.
* gnu/packages/databases.scm (bdb, bdb-5.3)[arguments]: Use invoke in the custom configure phase.
-rw-r--r--gnu/packages/databases.scm68
1 files changed, 33 insertions, 35 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 6dcebfb3f1..eb00ff5f8b 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -253,23 +253,22 @@ standard Go idioms.")
(("docdir[[:blank:]]*=.*")
(string-append "docdir = " doc "/share/doc/bdb")))
- (zero?
- (system* "./dist/configure"
- (string-append "--prefix=" out)
- (string-append "CONFIG_SHELL=" (which "bash"))
- (string-append "SHELL=" (which "bash"))
-
- ;; Remove 7 MiB of .a files.
- "--disable-static"
-
- ;; The compatibility mode is needed by some packages,
- ;; notably iproute2.
- "--enable-compat185"
-
- ;; The following flag is needed so that the inclusion
- ;; of db_cxx.h into C++ files works; it leads to
- ;; HAVE_CXX_STDHEADERS being defined in db_cxx.h.
- "--enable-cxx"))))))))
+ (invoke "./dist/configure"
+ (string-append "--prefix=" out)
+ (string-append "CONFIG_SHELL=" (which "bash"))
+ (string-append "SHELL=" (which "bash"))
+
+ ;; Remove 7 MiB of .a files.
+ "--disable-static"
+
+ ;; The compatibility mode is needed by some packages,
+ ;; notably iproute2.
+ "--enable-compat185"
+
+ ;; The following flag is needed so that the inclusion
+ ;; of db_cxx.h into C++ files works; it leads to
+ ;; HAVE_CXX_STDHEADERS being defined in db_cxx.h.
+ "--enable-cxx")))))))
(synopsis "Berkeley database")
(description
"Berkeley DB is an embeddable database allowing developers the choice of
@@ -307,28 +306,27 @@ SQL, Key/Value, XML/XQuery or Java Object storage for their data model.")
(("docdir[[:blank:]]*=.*")
(string-append "docdir = " doc "/share/doc/bdb")))
- (zero?
- (system* "./dist/configure"
- (string-append "--prefix=" out)
- (string-append "CONFIG_SHELL=" (which "bash"))
- (string-append "SHELL=" (which "bash"))
+ (invoke "./dist/configure"
+ (string-append "--prefix=" out)
+ (string-append "CONFIG_SHELL=" (which "bash"))
+ (string-append "SHELL=" (which "bash"))
- ;; Bdb doesn't recognize aarch64 as an architecture.
- ,@(if (string=? "aarch64-linux" (%current-system))
- '("--build=aarch64-unknown-linux-gnu")
- '())
+ ;; Bdb doesn't recognize aarch64 as an architecture.
+ ,@(if (string=? "aarch64-linux" (%current-system))
+ '("--build=aarch64-unknown-linux-gnu")
+ '())
- ;; Remove 7 MiB of .a files.
- "--disable-static"
+ ;; Remove 7 MiB of .a files.
+ "--disable-static"
- ;; The compatibility mode is needed by some packages,
- ;; notably iproute2.
- "--enable-compat185"
+ ;; The compatibility mode is needed by some packages,
+ ;; notably iproute2.
+ "--enable-compat185"
- ;; The following flag is needed so that the inclusion
- ;; of db_cxx.h into C++ files works; it leads to
- ;; HAVE_CXX_STDHEADERS being defined in db_cxx.h.
- "--enable-cxx"))))))))))
+ ;; The following flag is needed so that the inclusion
+ ;; of db_cxx.h into C++ files works; it leads to
+ ;; HAVE_CXX_STDHEADERS being defined in db_cxx.h.
+ "--enable-cxx")))))))))
(define-public es-dump-restore
(package