summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-12-23 19:14:12 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-12-23 19:48:21 +0200
commitbf5af9342c6dd364242c162db00436c9708e8d5b (patch)
tree69030391bfd16b1d8ef5526f1a1a1eb1012d3b9e
parent23ae876b91836fab51d3abf4095bc0d5e7f11bb9 (diff)
gnu: opencc: Use 'git-fetch'.
* gnu/packages/textutils.scm (opencc)[source]: Use 'git-fetch'.
-rw-r--r--gnu/packages/textutils.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index cda79231f1..1ea9c95407 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -758,12 +758,13 @@ indentation.
(version "1.0.5")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/BYVoid/OpenCC"
- "/archive/ver." version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/BYVoid/OpenCC")
+ (commit (string-append "ver." version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "01870gbkf711msirf3206k0ajaabypjhnx3fny5wikw0ladn9q8w"))))
+ (base32 "1pv5md225qwhbn8ql932zdg6gh1qlx3paiajaks8gfsa07yzvhr4"))))
(build-system cmake-build-system)
(native-inputs
`(("python" ,python-wrapper)))