summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-10-22 13:00:55 -0400
committerLudovic Courtès <ludo@gnu.org>2018-10-23 23:58:39 +0200
commit12995856e2fe31dfbc5cf97aa0d2c6c128aa7c81 (patch)
treebff5cbb29ea29d511dafe48718f019f16fe8ff35
parentb55697fbb430ae9a973eeae91f09213d1e603a9e (diff)
gnu: libssh: Fetch the source code more efficiently.
* gnu/packages/ssh.scm (libssh)[source]: Use the git:// protocol. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/ssh.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index e806fc80f2..b93cb03a14 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -71,8 +71,14 @@
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://git.libssh.org/projects/libssh.git")
- (commit (string-append "libssh-" version))))
+ ;; git.libssh.org does not support the fast "smart" HTTP
+ ;; Git protocol. The "dumb" HTTP Git protocol is extremely
+ ;; slow, and does not support shallow clones, so we use the
+ ;; plain Git protocol despite its flaws. This offers an
+ ;; incredible speedup and reduces the size of the the
+ ;; source by more than half.
+ (url "git://git.libssh.org/projects/libssh.git")
+ (commit (string-append "libssh-" version))))
(patches (search-patches "libssh-hostname-parser-bug.patch"))
(sha256
(base32