summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 11:11:28 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 12:13:48 +0200
commit171c3259fc47fd7c2ba3814bfffd4d716016cb6e (patch)
treea8b9742431aa7f1eb4b9aca73093cfa4834898be
parent6a95e3a3a4c97f20b66483b6bd7cac82ddfa0497 (diff)
gnu: Add go-github-com-btcsuite-btclog.
* gnu/packages/golang.scm (go-github-com-btcsuite-btclog): New variable.
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 2bea5579a2..6447e28405 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2632,3 +2632,29 @@ includes offsets, byte values in hex, and ASCII output (only when using Dump
style).
@end itemize\n")
(license license:isc))))
+
+(define-public go-github-com-btcsuite-btclog
+ (let ((commit "84c8d2346e9fc8c7b947e243b9c24e6df9fd206a")
+ (revision "0"))
+ (package
+ (name "go-github-com-btcsuite-btclog")
+ (version (git-version "0.0.3" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/btcsuite/btclog.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "02dl46wcnfpg9sqvg0ipipkpnd7lrf4fnvb9zy56jqa7mfcwc7wk"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/btcsuite/btclog"))
+ (home-page "https://github.com/btcsuite/btclog")
+ (synopsis "Subsystem aware logger for Go")
+ (description "Package @command{btclog} defines a logger interface and
+provides a default implementation of a subsystem-aware leveled logger
+implementing the same interface.")
+ (license license:isc))))