summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 12:16:18 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 12:27:59 +0200
commit247b1bd2b65ec51292655c9d5998c77616ba2736 (patch)
tree912235a3b96d0a194fc6168b7ec19f4c49838ce6
parent56eb7bd33c7c698253be91a932ed3cc8fc85ab6f (diff)
gnu: Add go-github-com-ipfs-go-ipfs-cmdkit-files.
* gnu/packages/ipfs.scm (go-github-com-ipfs-go-ipfs-cmdkit-files): New variable.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/ipfs.scm52
2 files changed, 53 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 47883f829e..6ae7ff42f5 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -234,6 +234,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/imagemagick.scm \
%D%/packages/inklingreader.scm \
%D%/packages/inkscape.scm \
+ %D%/packages/ipfs.scm \
%D%/packages/irc.scm \
%D%/packages/iso-codes.scm \
%D%/packages/java.scm \
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
new file mode 100644
index 0000000000..ff446da32b
--- /dev/null
+++ b/gnu/packages/ipfs.scm
@@ -0,0 +1,52 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages ipfs)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix git-download)
+ #:use-module (guix build-system go)
+ #:use-module (gnu packages golang))
+
+(define-public go-github-com-ipfs-go-ipfs-cmdkit-files
+ (let ((commit
+ "386fcf8f18a185ec121676665fe2d9574496048d")
+ (revision "0"))
+ (package
+ (name "go-github-com-ipfs-go-ipfs-cmdkit-files")
+ (version (git-version "1.1.3" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ipfs/go-ipfs-cmdkit.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0qk6fshgdmhp8dip2ksm13j6nywi41m9mn0czkvmw6b697z85l2r"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:unpack-path "github.com/ipfs/go-ipfs-cmdkit"
+ #:import-path "github.com/ipfs/go-ipfs-cmdkit/files"))
+ (home-page "https://github.com/ipfs/go-ipfs-cmdkit")
+ (synopsis "Shared types, functions and values for go-ipfs")
+ (description "@command{cmdkit} offers some types, functions and values
+that are shared between @command{go-ipfs/commands} and its rewrite
+@command{go-ipfs-cmds}.")
+ (license license:expat))))