summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 11:48:27 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 12:13:49 +0200
commit2e42e587b43106980dbd8a6bfee2fd644c1a7f53 (patch)
tree74a78c2f4f2751aaef5005281e754885e5ee19a5
parent9a7f1575713be1050eedc611047b9603fdbd1bf6 (diff)
gnu: Add go-github-com-multiformats-go-multihash.
* gnu/packages/golang.scm (go-github-com-multiformats-go-multihash): New variable.
-rw-r--r--gnu/packages/golang.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d8126d8916..ab78038649 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2875,3 +2875,34 @@ MurmurHash revision (aka MurmurHash3).
Reference algorithm has been slightly hacked as to support the streaming mode
required by Go's standard Hash interface.")
(license license:bsd-3))))
+
+(define-public go-github-com-multiformats-go-multihash
+ (let ((commit "97cdb562a04c6ef66d8ed40cd62f8fbcddd396d6")
+ (revision "0"))
+ (package
+ (name "go-github-com-multiformats-go-multihash")
+ (version (git-version "1.0.8" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/multiformats/go-multihash.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "02wd9akrwy4y5m0nig9m24p14bjjgb4n1djydrq8cm4yhbvjrrk0"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/multiformats/go-multihash"))
+ (native-inputs
+ `(("go-github-com-mr-tron-base58" ,go-github-com-mr-tron-base58)
+ ("go-github-com-gxed-hashland-keccakpg" ,go-github-com-gxed-hashland-keccakpg)
+ ("go-github-com-minio-blake2b-simd" ,go-github-com-minio-blake2b-simd)
+ ("go-github-com-minio-sha256-simd" ,go-github-com-minio-sha256-simd)
+ ("go-github-com-spaolacci-murmur3" ,go-github-com-spaolacci-murmur3)
+ ("go-golang-org-x-crypto-union" ,(go-golang-org-x-crypto-union))))
+ (home-page "https://github.com/multiformats/go-multihash")
+ (synopsis "Multihash implementation in Go")
+ (description "Multihash implementation in Go.")
+ (license license:expat))))